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Introduction

Task Killer can display all of the modules (DLL's and EXE's) currently loaded in Windows.    In addition, 
Task Killer can:

Terminate any module
Decrement the usage count of DLL's
Create multiple module lists showing the state of the system at different times
Compare module lists in side-by-side windows
Save module lists to files
Print module lists

Task Killer is invaluable to programmers, technical support personnel, network administrators, and power 
users.    DLL's which have been left in memory can be freed and runaway programs can be terminated.    
You can determine where DLL's have been loaded from, as well as sort out DLL conflicts.

Task Killer requires an IBM PC or compatible running Windows 3.1.



Registration

REGISTRATION FEES

Single License $ 15
2-10      computers each: $ 12
11-30    computers each: $ 9
31-60    computers each: $ 7
more than 61 computers each: $ 5

Washington State customers, please add sales tax.

To register, send a check or money order:

Hyperion Microsystems
Box 243
Edmonds, WA    98020

Or, register with CompuServe's Software Registration Service.    Simply GO SWREG and follow the 
menus.    Task Killer's registration ID is 1226.

See also
Order Form



License Agreement

Thank you for trying Task Killer.    Continued use of this program automatically constitutes acceptance of 
this disclaimer of warranty:    Task Killer is supplied as is.    The author disclaims all warranties, expressed 
or implied, including, without limitation, the warranties of merchantability and of fitness for any purpose. 
The author assumes no liability for damages, direct or consequential, which may result from the use of 
Task Killer.

Task Killer is a "shareware program" and is provided at no charge to the user for evaluation.    Feel free to 
share it with your friends, but please do not give it away altered or as part of another system.    The 
essence of "user-supported" software is to provide personal computer users with quality software without 
high prices, and yet to provide incentive for programmers to continue to develop new products.    If you 
find this program useful and find that you are continuing to use Task Killer after a reasonable trial period, 
you must make a registration payment of $15 to Hyperion Microsystems.    The $15 registration fee will 
license one copy for use on any one computer at any one time.    You must treat this software just like a 
book.    An example is that this software may be used by any number of people and may be freely moved 
from one computer location to another, so long as there is no possibility of it being used at 
one location while it's being used at another. Just as a book cannot be read by two different persons at 
the same time. 

You are encouraged to pass a copy of Task Killer along to your friends for evaluation.    Please encourage 
them to register their copy if they find that they can use it.    All registered users will receive free technical 
support for the product.

Send questions, comments, and suggestions to the following address.

Hyperion Microsystems
Box 243
Edmonds, WA    98020

CompuServe #76370,3353

See also
Registration



Order Form - Task Killer Version 1.2

To register, send a check or money order with this form to:

Hyperion Microsystems
Box 243
Edmonds, WA    98020

To print this registration form, click on Print Topic in the File menu.      Payments must be in US dollars 
drawn on a US bank.

You may also register with CompuServe's Software Registration Service: 
GO SWREG and follow the menus.    Task Killer's registration ID is 1226.

Task Killer

quantity: _____ @ $______ each 
subtotal: _____
Washington residents 
add 8.5% sales tax: _____
Total Payment _____

Name: ________________________________________
Company: ________________________________________
Address: ________________________________________
City, State, Zip ________________________________________
Country: ________________________________________

Day Phone: ________________________________________
Work Phone: ________________________________________

Electronic Mail Address:___________________________________

Comments, Questions, and Suggestions:



File menu commands

The File menu offers the following commands:

New List Creates a new module list.
Open Opens an existing module list.
Close Closes a module list file.
Save Saves a module list using the same file name.
Save As Saves a module list to a specified file name.
Print Prints a module list.
Print 
Preview

Displays the module list on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Exit Exits Task Killer.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple module lists in the application window:

New Window Creates a new window and a new module list.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Refresh Refills the module list with current information.
Window 1, 
2, ...

Goes to the specified window.



Options menu commands

The Options menu offers the following commands, which enable you to specify your own 
configuration preferences:

Task List Specify your preferences for task lists.
Report Specify your preferences for printed reports.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New List command (File menu)

Use this command to create a new module list in Task Killer.    

You can open an existing module list with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing module list in a new window.    You can open multiple 
module lists at once.    Use the Window menu to switch among the multiple open module 
lists.    See Window 1, 2, ... command.

You can create new module lists with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Task Killer defaults to files with a ".lst" extension.
Drives

Select the drive in which Task Killer stores the file that you want to open. 
Directories

Select the directory in which Task Killer stores the file that you want to open.
Network...

Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active module list.    Task Killer 
suggests that you save changes to your module list before you close it.    If you close a 
module list without saving, you lose all changes made since the last time you saved it.    
Before closing an untitled module list, Task Killer displays the Save As dialog box and 
suggests that you name and save the module list.

You can also close a module list by using the Close icon on the module list's window, as 
shown below:



Save command (File menu)

Use this command to save the active module list to its current name and directory.    When 
you save a module list for the first time, Task Killer displays the Save As dialog box so you 
can name your module list.    If you want to change the name and directory of an existing 
module list before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active module list.    Task Killer displays the Save As
dialog box so you can name your module list.    

To save a module list with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a module list with a different name.    A filename can contain
up to eight characters and an extension of up to three characters.    Task Killer adds the 
extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the module list.

Directories
Select the directory in which you want to store the module list.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
module lists you closed.    Choose the number that corresponds with the module list you 
want to open.



Exit command (File menu)

Use this command to end your Task Killer session.    You can also use the Close command on 
the application Control menu.    Task Killer prompts you to save module lists with unsaved 
changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Task Killer, such as File Open.    A check mark appears next to 
the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Task Killer,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new module list.

Open an existing module list.    Task Killer displays the Open dialog box, in which you 
can locate and open the desired file.

Save the active module list or template with its current name.    If you have not 
named the module list, Task Killer displays the Save As dialog box.

Remove the currently selected module from memory.

Print the active module list.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Task Killer window.    To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



Task List Options dialog box

The following options allow you to specify your preferences for the format of new task lists:

List Type
Choose whether task lists should be displayed in a 'Brief' or 'Detailed' format.    'Brief' 
listings show module name, usage count, and filename path.    'Detailed' lists show this 
information plus file size and file time/date.

Types
Choose which type of module to display in new lists.

Common Modules
Common Modules are the Windows components which are found in most Windows 
installations.    Select which of these to display in new task lists.



Report Options dialog box

The following options allow you to specify your preferences for the format of printed task list 
reports:

Title
Specify a title for your reports.    The title text can be a maximum of 60 characters.

Header
Choose whether to display page numbers, the current date, and the current time.

Font
This dialog will allow you to choose a font for the report.    This can be useful if the listing 
does not fit on the page with the default printer font.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You
can open multiple module list windows to display different parts or views of a module list at 
the same time.    If you change the contents in one window, all other windows containing the 
same module list reflect those changes.    When you open a new window, it becomes the 
active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open module list window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this module list 
window.



1, 2, ... command (Window menu)

Task Killer displays a list of currently open module list windows at the bottom of the Window 
menu.    A check mark appears in front of the module list name of the active window.    
Choose a module list from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Task Killer and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Task 
Killer.



Context Help command 

Use the Context Help command to obtain help on some portion of Task Killer.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the Task Killer window, such as another Toolbar 
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and module list.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Module list Control-menu button
Maximize button
Minimize button
Name of the application
Name of the module list
Restore button



Scroll bars

Displayed at the right and bottom edges of the module list window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the module list.    You can use 
the mouse to scroll to other parts of the module list.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Task Killer window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a module list window.



Next Window command (module list Control menu)

Use this command to switch to the next open module list window.    Task Killer determines 
which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (module list Control menu)

Use this command to switch to the previous open module list window.    Task Killer 
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single module list, the Close command on 
the module list Control menu closes only one window at a time.    You can close all windows 
at once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a module list window



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>

    




